0

Keep getting this error no matter what version i install – Access to the path ‘C:\Program Files\Lockheed Martin\Prepar3D v4\Sound\ATC\Evp_E_Fsx_FSX_D2.4.gvp.evptmp’ is denied.

Posted new comment

Unfortunately one of the more unclear Windows error messages – I assume it is for security reasons they do not include why it is denied in the error. 🙁

1) Do you have anti virus software installed – sometimes they can lock a file just after it is created. I do not think this is the case here, but worth checking
2) What happens if you start EditVoicepack by right clicking it and select “Run as administrator”

Problem solved! So i was installing Edit Voice Pack as ‘Administrator’ but not opening the program as ‘Administrator’. I was only left clicking the icon from the Start/Programs Menu. The solution was to send the Icon to desktop and open by right clicking and ‘Run as Administrator’ and it worked perfectly. It must be noted that i also turned off Windows Defender Security Centre in Windows 10. Quality product with amazing support. Thanks for caring n sharing Lars….

Ehh…. quality could clearly be better, because this is a bug. It should have promoted you for admin access automatically, but clearly I managed to break that. I expect if you run it again, it will prompt correctly now the file is created – but can’t say for sure, this is something I need to investigate for a future version. I recommend you turn Windows Defender on again, I think it was innocent this time 🙂
I’ll add an answer with the solution so it is clear to others what to do in this case without they have to read our comments.

Lars your too hard on yourself. 99% of all programs need to be ‘Run as Administrator’ for them to work correctly. Indeed Windows Defender Security Centre wasn’t the issue and recommend that no one disable it. Thanks again Lars. Truly appreciate the prompt and helpful product support….8)

Strange, I checked the code and it does evaluate for write permission to that folder. So the check must be wrong, but I have no idea why. 🙁 Unfortunately I can’t reproduce it. No space on my system drive to install P3D in the Program Files folder 🙂
Oh well, hopefully I figure it out in the future – it works on most systems without any problem.